Customer Feedback

Website Built Around The Customer

This entire website has been built to help the Bullfrog Spa Customer. You made the investment in a quality Bullfrog Spa and we are here to help with your service and parts needs. As you the Bullfrog Customer are the most important part and the entire reason for this website, we value your feedback. Leave your comments below about the service, website or related topic.

Show Your Tangible Appreciation

If The Spa Master has helped you on chat or this website’s information has helped (done by The Spa Master) then you can Tip The Spa Master!

98 thoughts on “Customer Feedback

  1. Richard Davidson
    I am a little embarrased to admit that I overtightened and broke the collar that attaches to the wet end of the pump on my 2007 Bullfrog Spa, Model 331. Is there a way to replace just the collar or will this require major surgery?

  2. We are thinking of buying a Tadpole BF02. It is in great condition. We were wondering how much they sold for and how much do you think it is worth? Is it easy to maintain? Thanks, Linda

    1. When considering a used tub, you can’t do better than a Bullfrog Spa. Check your email for more information from me.

  3. I was looking for a face plate for a jet on the oscillator jet pak. Really had little hopes of finding one but went to the online chat and described what I was looking for and The Spa Master had me an answer in about 30 seconds. What a pleasant surprise to find someone so knowledgeable and helpful.

  4. I have been ordering parts for my BullFrog Spa for several years. Always great prices and I alway find what I need and my orders are received quickly. Love the online chat, always attentive and helpful. A++

  5. You answered both my questions faster than I could ask them! LOL Great to know we can add the wifi and fix the clips with no problems!

  6. I have a 562 with the Premier topside control. Main control is BF01 Mach2. Topside control won’t respond to button pushes, such as to change temperature or set time. It also is displaying incorrect information, such as indicating pumps running when they aren’t. It is not locked (no padlock symbol or PL light on). I’ve cycled power on the entire system (at main breaker feeding hot tub) and also toggled the A12 switch during a power cycle; upon power-up the spa appears to otherwise operate normally through priming, pump1 cycling on from time to time, etc. Is this likely a failed topside control, or a problem in the BF01 itself? Thanks!

    1. If you have auxiliary pump controls, try unplugging them and see if the topside works correctly. Otherwise it sounds most likely to be a topside, but still could be a board issue.

        1. Sorry, one more question if you don’t mind. The tag on my topside control says Balboa ML700, S/N begins 52798-01. Is the 65-1186 control pad on this website correct? Since there’s no returns allowed, just want to make 100% sure I’m getting the right part.

          1. If your topside is the 8 button Premier control, then yes this would be it. Don’t forget the overlay as well 65-1860.

  7. Hi, I have a 462. When I turn it on, it runs thru all modes and runs pumps – as soon as the heater comes on, it trips the breaker. Can this be anything else other than a bad heater? Thanks

  8. Was great that I had the ability to ask questions before spending a lot of money. The online support also told me how to save some money which was great too. Also – I had questions about replacing the part and they helped with that! Fantastic customer service!!

Leave a Reply

Your email address will not be published. Required fields are marked *